Honeywell (Dahua) NVR Remote Access Issue/Question

Hey guys,

I was wondering if I could get some suggestions regarding an issue with this rather simple system for a guard house / entry & exit gates in a private community. The system consists of 6 IP cameras (1080Px6) connected to a Honeywell Performance IP NVR and 2 LPC analog 960H cameras connected to an HD-CVI 4 CH DVR (more reliable than affordable encoders I have tested). The NVR has a built-in POE switch and I have no problem accessing the cameras/NVR/DVR via the web browser and desktop app as well as the mobile apps (Honview Touch) when on the local network using the static IP addresses on the network.

All ports have been forwarded in the router for both recording devices but I cannot get a good connection when remotely accessing the system using the Honeywell free DDNS service. I have no issue doing the same thing using IC Realtime's similar software apps (all analog cameras though) from my office. The new system will connect remotely but will time out within minutes if not seconds (both recorders) and will have difficullties sometimes reconnecting. And since the recording devices are located in an unmanned guard house, the main access mode will be remotely via the DDNS addresses.

Any ideas or suggestions on how to troubleshoot further would be useful as I've been stuck for a few days now with Honeywell tech support being willing and available but so far unable to find the issue.



Can you access the NVR directly on its web interface from the outside? That is, make sure port 80 is forwarded to the NVR, then hit the WAN IP from an outside browser, and see if it maintains connection? Or configure the mobile app to use the IP rather than going through the DDNS?

Hi Matt,

Thanks for asking. I have not tried to log in via the ddns address and have not tested the current WAN IP remotely on a browser either. I basically use the apps which connect fine but after some experimentation, I find that only a few cameras my connection remains solid (I had the iPad app going for 3 hours +). When I have more than 4 cameras, or both recorders streaming to the app simultaneously, the connection times out.

I have used the browser on the LAN with no issue though. I have not been able to do so using the WAN IP or the ddns address yet. I need to figure out why but connectivity via the desktop app and mobile apps has been verified and working.

Usually the DDNS system with these sorts of things involves the DVR making a connection out to the manufacturer's server, then your remote app connects with that, and is then forwarded on to the DVR. In some cases the DDNS is STRICTLY a dynamic DNS and your app connects straight to the DVR either way.

The point of trying it directly from the outside via the site's WAN IP is to remove the remote-connect service and DDNS entirely from the equation - if that works fine, then your connection is good and there's an issue with the service.

Next step would be to use the DDNS name for a direct connection (, or whatever it is) - DDNS problems should only cause an issue with initial connection.

If the connection uses a "tunnel" via Honeywell's service, that adds multiple levels of potential issues. I haven't delved into exactly what method Dahua and/or Honeywell use here, though.

If DDNS is resolving the WAN address it wont be affecting this issue. I would look more to bandwidth on your network/ISP. What service are you using for internet? Run a and a and see what you get. Also I would refrain from using default ports I.E> 80 for Web/HTTP as your ISP may have objections to that. Best practice is to always select ports above 1024 for your services. This is where I would start.

***EDIT** Based on response above. You are testing right now on the local net only and having this issue? You might want to try lowering your streams resolution and framerate and see how it behaves. I know at least on the Hik units, their processing power is a bit low and very easy to overload if trying to max or use very high settings.


On the local network, my connection via the browser or the apps using the LAN static IP's are solid. Only when I try to remotely view using DDNS settings am I having issues at this point.

I'll play with resolution and frame rates as well, just to see if anything changes. The issue seems to be isolated to the use of the DDNS addresses. I can only test it locally using cellular service on my phone. It disconnects on the phone within less than a minute and remains solid on the iPad on the local wifi network. I am currently testing to see if the 4-camera view / connection will remain solid on the WAN access.

I'm positive it's some kind of setting or adjustment that can be made. Just not sure what.

Thanks again for the help!

Thanks David.

I'll make the changes you recommended. Bandwidth should be 2Mbps up, 20 Mbps down (DSL/Century Link). It was recently installed.

The IP cameras are powered straight from the NVR and on their own subnetwork (10.1.1.X).

There is no other activity network wise other than the 2 recording devices.

I will be on site within the hour implementing the changes and doing additional testing AND probably calling tech support again.

I'll post what I find out here if anything.


Well, It turns out the upload bandwidth from the site is lower than expected so after simple testing and math, I concluded it is a bandwidth issue (almost embarrassed to say).

Thanks for the feedback guys.


Darn, too late to this thread to jump in and say that while the bandwidth "should be" 2Mbps up, it probably is not. The ISP usually offers a service that is "up to" the cited bandwidth. That means it may only sometimes reach or exceed that speed.

The only way to know is to test. Even then a couple more caveats:

1. Test results acheived one minute may be transient. You really need to test under different conditions to get a feel for the average that's likely to be available most often.

2. Many speed test tools provide a maximum number at the end of the test, but not necessarily an average. Look for the average as that is what will be necessary for a streaming connection. This is especially true of you're using a real time technology as it is--well--real time and as such requires a stable channel bandwidth.

Matt, I tried the WAN IP as you suggested and it wasn't a noticeable performance improvement or change. I also tried another DDNS service as well just in case as I have a Pro account with Dyndns. I tried a lot of things to look for improvements just to make sure there was nothing other than upstream bandwidth issues. Much of the products used on this project were new so I wasn't sure at first. Thanks Steve for your input as well. Alan


There are hundreds of DDNS services available, some free, some paid. The problem with these services is that you and your customers are in the mercy of their resources and infrastructure. We have designed and implemented our own DDNS server in the cloud utilizing Linux, Bind9, and a few Perl scripts. Paid DDNS services are almost as much as a dedicated IP; with some of the free services, you have to login to the portal and re-activate the free subscription. A few hundred customers, this becomes an administrative headache. This may or not work for you, but has worked well for our customers and us; something to think about.

I've had the same problem a few times with Hikvision, when this happens I typically plug in googles DNS in the ip configuration and everything works fine.