Problems Integrating AD PTZ With Milestone?

I have a site with a legacy American Dynamics ADVEIPSD35N PTZ camera which I am attempting to add into Milestone. Unfortunately, there is no driver written for this camera. The camera uses port 5001 according to the old Intellex Ultra NVR in place. I have attempted to connect to it with both VLC and the Milestone Universal driver using what I believe is the appropriate RTSP stream url according to soleratec.com. I have also tried a similiar URL that Soleratech.com shows as being functional with the ADVEIPSD35P model, which I am assuming is just a PAL version. I have updated it to the latest firmware and the Milestone server to the latest device pack. No luck. Has anyone ever successfully added this to any system using the RTSP stream?

While the camera claims ONVIF compliance, I have not been able to add it via Onvif.


Have you tried either:

rtsp://ip:554/ch0_0.h264

rtsp://ip:554/live1.sdp

Do you have Wireshark or tcpdump?

Edit: no harm in trying it with port 5001 as well...

I tried both of the above, no avail. I just ran Wireshark and opened up a video stream direct from the camera via web browser in their GUI. I see packets pertaining to RTSP... not quite certain how to interperet this. I see RTSP requests and responses stating service unavailable.

I use this program sometimes: http://www.videohelp.com/software/URL-Snooper

Wireshark is great but overly complex for simple tasks.

Install that, set protocol filter to RTSP, filter IP address to the camera's IP, then start sniffing.

Then, open the camera's web interface and look at live streams. You should start seeing RTSP URLs populate in the sniffer.

I'd demonstrate this but I'm answering on my phone and don't have a computer handy.

"While the camera claims ONVIF compliance, I have not been able to add it via Onvif."

Technically, they don't claim it's compliant. They say it's 'compatible' :) It's not on the official ONVIF conformant list so that's not a good sign. Also, this is an older camera, so even if it has ONVIF code, it could be old and non-conforming to current ONVIF.

Btw, if you do connect to Milestone via RTSP, since RTSP does pass / support PTZ controls, how do you plan to control the camera?

I have forwarded this to TSP / AD to ask for comment.

Technically, they don't claim it's compliant.

I can't let them off the hook so easily...;)

Here's a pdf that details in depth the cameras puported ONVIF compliance.

VE IP SpeedDome ONVIF Compatibility

The VE IP SpeedDome with software version 2.0 or higher is compatible and compliant with versions 1.0, 1.01, and 1.02 of the ONVIF core specification; however for PTZ control it will only communicate using 1.01 or the 1.02 ONVIF protocol standards.

VE IP SpeedDome ONVIF High Level Design Summary

The American Dynamics VE IP SpeedDome with software version 2.0 or higher supports the ONVIF functions listed in the following table. This table also indicates which of these functions are used within the illustra Connect tool and are verified by the ONVIF Standard Compliance tool: (function by function table)

It also says using illustra Connect as an AD ONVIF test tool, that it will root out the stream URI's for you:

Select the device and then go to the advanced device diagnostics page. Select the URI in the ‘Stream URI’ text control and copy it. Open this URL using a viewer application (e.g. QuickTime or VLC) to view a live feed.

Key takeaways: Firmware must be version two, reset camera to defaults, try using Illustra Connect...

Nice details!

Even if it is 1.02, it is certainly not officially conformant because it is not on the archived page.

And even if it is 1.02, we know from testing and this is confirmed from ONVIF, that devices with 1.02 are far less likely to work than devices that are S / 2.x

Tried all of the takeaways already, that was the first stop on this train. It is not. As for PTZ control I know it is an issue, I just want the video being recorded in Milestone so I can rip out an old system that now exists for only 2 cameras. Like most customers with older systems they have too many PTZs and all of them are set on one view, rarely panned, tilted, zoomed, or cleaned.

Sorry to hear. :(.

But I think, based on reading that pdf, that this camera if not malfunctioning, should be easily discoverable. It's not some weird, trying to obscure itself camera.

If you haven't given up:

Does the ONVIF diagnostic totally fail in Illustra Connect, or is there any info returned?

Can you export those RTSP entries from Wireshark and post them?

Maybe it's just the port that were missing... If so, you can do a netstat -a on the PC while its streaming, you should be able to catch the remote port# that way.

Also, I second Ethan's suggestion of URL-scanner. It's always possible that the camera is using a homebrew non-RTSP scheme or encapsulation though...

Chris, thank you for your persistence and detail. My wire shark skills are not quite up to snuff. I was unable to see any valid packets applying to the AD camera IP with the URL scanner, though I can see every Axis camera RTSP stream without issue in that app. I will try again with Wireshark and post the results for someone more skilled to look at the results.

Looking at the manual, I would say that it makes sense why url scanner is not showing anything. It would appear that the web client and the VxClients will default to using ACC over a protocol called ntlx (Intellex?) which probably is run inside of http.

On the other hand there is still good reason to believe that there is a RTSP stream to attach to. ONVIF must use one, and even if their implementation of ONVIF is spotty, they must have some URI that could be used if we can figure out what its called.

Its certainly one of those times that a Universal ONVIF URL would have come in handy.

One program I have used in the past to reveal the URL is ONVIF Device Manager, which can be downloaded here. Then factory default the camera (to make absolutely sure it will use ONVIF) and run ODM. Do NOT run the webpage or VxClient before running ODM. Then if ODM finds the camera, choose live view and underneath the picture it should give you the URI.

Also, URL-Checker/Wireshark may have relevant RTSP information at this point. Even if no stream is showing in ODM, Wireshark may show the at least show the SOAP call and response which should give up the URI.

Undisclosed 1, I just was able to download the AD installers toolkit from the AD site. It requires a login, but here is the link to use once logged in.

If you have not used this yet, I strongly suggest you try it before doing anything else. After it installs, one of the Icons is Illustra Connect. It also shows the individual ONVIF calls etc...

I'm thinking it will work, but who knows???

AD responded.

Here is the syntax for the RTSP URL. Note that the Width, Height and FPS have to align with the stream settings made on the camera. I can’t guarantee this will solve this but it is a start.

The URL should conform to the following format: rtsp://<ip>/Video?<name_value_pairs>&<name_value_pairs>&<name_value_pairs>

• Example 1 (MPEG4): Video at 720x576 using a MPEG4 codec at 30 FPS

o rtsp://192.168.0.2/Video?Codec=MPEG4&Width=720&Height=576&Fps=30

• Example 2 (H264): Video at 720x576 using a H264 codec at 15 FPS and No Audio.

o rtsp://192.168.0.2/Video?Codec=H264&Width=720&Height=576&Fps=15

• Example 3 (MJPEG): Video at 640x480 using a MJPEG codec at 25 FPS with a Quality level of 75 and No Audio

o rtsp://192.168.0.2/Video?Codec=MJPEG&Width=640&Height=480&Fps=25&Qual=75