Problem With Remote Viewing

A customer of ours have 4 IP cameras installed of SAMSUNG. I am frequently unable to access the NVR through public IP remotely. The customers public IP is STATIC. When i just power OFF the router for 2-3 minutes and power it ON then its working fine. But after 2-3 days again i am facing the same problem . Is this the router fault or any other problem . Need Suggestions ??


Have you tried using one of the Samsung free DNS services rather then doing IP address?

Using a DDNS service (I am assuming this is what you meant, as opposed to DNS), why would you expect this to help?

imo, this would just introduce an additional point(chance) of failure, as the DDNS service just maps to the IP address stored in it's 'current IP' database.

If directly connecting via IP address doesn't work (without rebooting the router), why would DDNS be any better?

Good catch, I did mean the ddns service- Samsung has some pre set up in some of the DVR/NVR solutions I've seen in the past. Theoretically it should work no better, but using the pre set up service from Samsung I've had good success when other routes were intermittently bad

Check your router and port forwarding rules in relationship to NVR hopefully not running DHCP? Who setup machine is there a second router behind modem? Port 80 should be open or any other ports you opened for phone app etc. Are you testing with a port checker tool onsite and or remotely when you run into this issue? I just had a machine using Windows 10 I had to go to "compatibility view" and add IP address with IE. Using DDNS is preferred method now days. Have any screen shots of setup and what does Samsung tell you have you spoken with tech support?

"Check your router and port forwarding rules in relationship to NVR"

Not sure how checking port forwarding rules would help: if rebooting the router solves the connectivity issue, then the port forwarding rules have been correctly applied.

"is there a second router behind modem?"

If there were a second router behind the modem (or even a combo unit) - and it hadn't already been bridged - then the system would never have worked, and rebooting his router to solve the connectivity failure would also not work.

"Are you testing with a port checker tool"

Agree. This is one of the first things that should be done.

"Using DDNS is preferred method now days."

Not sure I agree with that.... DDNS introduces an additional point of failure, imo (though it can be 'easier' to deploy)

I would swap in a new router for the one you are rebooting all the time. While any number of things could be the issue, it appears (from the OPs description) that the device that may be failing is the router.

Because support costs time and money, imo it is most often best to start (when one device appears to be the problem) with the 'undertaker' approach vs 'surgeon' :)

It takes less time and money to kill it and swap in a new one, than it does to perform surgery on the entire system.

Not saying system surgery may not be required, but I'd start with the device first.

Yes, it is very possibly a bad router or bad firmware on the router. I have seen a very similar issue with a Cisco/Linksys RV100W router that had defective firmware that took years for Cisco to resolve. That particular router needed rebooted weekly to maintain open firewall ports.

I had opened port 4000,80,81,554-558(TCP/UDP) , 4520-4524(TCP).

i should see by Swap a new router
Does the firmware up gradation of the router will help ??

I do not want to go with DDNS because customer is paying money for STATIC IP.

DDNS isn't the issue, unless his ISP isn't honoring the Static IP. You can test this onsite really easy. Simply go to canyouseeme.org and check that the IP hasn't changed from the Static. And while there, see if your port forwards are still active.

Also, this may be possible as well, check to make sure the DVR hasn't changed its IP address. I'm sure you've checked this, but it is a possibility.

I'd lean towards the router. I think the key is you need to reboot it to regain connectivity. I like others also suspect it is a firmware issue. Try upgrading the firmware or a different router that is known to work properly.