NTP Server Issues

We are experiencing an issue where we use an internal NTP Server, so we have set up the recorders (servers) and set our time on the individual cameras as well. However when they are deployed to site the cameras actually change what NTP IP address was programmed and replace it with the recorder (server) address and now the time is out of sync. Has anyone else experienced this or know if the camera time shouldn't be set as it pulls directly from the recorder (server) ? Does one supersede the other? This has happened with a couple of different camera brands and is becoming a big issue. Video is new to our group so any suggestions would be great, thanks everyone!


Some VMS's will actually push time server settings to a camera. Can you share the VMS and cameras that are affected?

Otherwise maybe check in the VMS configuration to see if there is a 'force' or 'push' option in the time server settings. It sounds like the VMS wants to be the time server for the cameras, rather than allow the cameras to sync to their own server.

Hi Matt,

It has been Panasonic and exacq cameras and recorders so far.

Thanks

Exacq forces itself as the NTP server unless you override it. You can have it use a different server on the second tab of the "System" menu, seen below. Enter the server you want the cameras to use, and Exacq should push that address to them when you add them.

Ethan in the example you show above, would choosing enable override actually have any effect on the actual time that the cameras have, since the IP's are the same?

I understand that you were just illustrating where and how to enable the override, not to give a specific example, but it sounds like Undisclosed A would also be setting both IP's to the same address.

Moreover, whether exacq was overwriting the camera's ntp server or not, how could the time get out of sync? Since whether the cameras are pointing to the exacq server which points to the internal ntp or everyone points to the internal ntp on their own, they would receive the same time, no?

you may have to disconnect and reconnect the cameras to push the event.

also there is a task that runs in wondows under task scheduler that reconciles with the NTP... try changing that to update more requently than once a week... i set mine for once every few hours.

Part of ONVIF is time sync between cameras and server An easier way would be to have the server use the preferred time server and then push updates to the cameras as planned. Or so I have been told.

Did the override work? Did it actually change the setting on the camera of the ntp server ip address?

The way I remember it working, (from researching a different exacq ssue), is that the cameras are set to point to the VMS for time sync, regardless of whether the override is checked or not.

When the Override is checked the VMS continues to use the ntp listed as the "Time server" but will serve the cameras the time of the external "IP Camera Time Server" instead. In Ethan's example they are set to the same ntp server anyway. This is the way I read it used to work a few years ago, I can't tell from the documentation if it still does.

But if the override is checked and the cameras are still pointing to exacq, its likely because exacq is just proxying the override ntp time data to the cameras directly, without changing config.

Regardless, I'm curious if there was a resolution to this...

it has always been my understanding that with exacq, the ntp server listed is where the server gets its time. the cameras will get ntp address as the server, with an ip depending on which nic they are on. if you want to use the override featue, this will force another source of ntp. cameras all run on gmt time zone. in som instances, though, without override, the eaxacq server may send out 127.0.0.1, which means cameras will not have right time. in this instance i may override to the servers ip address. if you are connecting to cameras on multiple nics, you can not so this. always check to make sure all cameras are showing the right and same time to verify that the cameras have proper ntp service that they can access. also, if routed network, make sure cameras have the right gateway and mask configured. if the ntp has a dns name, make sure cameras have the right dns address configured.