Milestone VMS Disconnecting From Hikvision IP Camera, What To Do?

I have an issue using Xprotect Essential with Hikvision DS-2CD2032-I cameras that I wonder if anyone has encountered and solved. In the Xprotect client viewer the Hikvision cameras randomly loose connection for a couple of seconds on a fairly constant basis.

Talked to Milestone and they said it was because I was using a windows 10 PC as the server and 10 was not supported, so I pulled out 10 and put in 7. This is an new Intel I7 with 16GB ram and a 4GB Video card, so I don't think it's performance related. All the cameras are stable in the Xprotect management application or in a browser, but in the Xprotect client they drop all the time. I’ve tried dropping resolution, frame rate to 8 and setting at VBR and CBR high caps and low, dropping quality, turning off firewalls. All changes make no difference.

Milestone now tells me I need to roll back the firmware on the cameras (it’s 8.2 vs. 8.1). My customer is about to make me rip the system out, anyone encountered and solved this issue.

William, did Milestone explain why the roll back to 8.1 would solve this?

No they are grasping at straws I think, their logic was that the earlier firmware was what they tested the cameras with.

I am also forwarding this to Hikvision to see if they have anything. I am sure they will want to know that one of their cameras is having an issue with the latest Milestone versions.

"Milestone now tells me I need to roll back the firmware on the cameras (it’s 8.2 vs. 8.1)"

Btw, Ethan just pointed out, that Milestone probably wants you to rollback the device pack on your XProtect installation (8.2 refers to Milestone's side, Hikvision is on 5.2 or 5.3, etc.)

William- I am from Hikvision. Have you worked with your local Hikvision representative?

I have forwarded this to our Integration Manager in the US office for further comment.


No not yet I was hoping someone had just run into this and it was not an isolated case.

John was correct the Hikvision is on 5.2 and Milestone tested with 5.1.

William, you mean 8.1 on Milestone? It's important to make sure we are clear about the right versions.

Btw, if you are on Hikvision 5.2, it's best to immediately upgrade to 5.3, e.g., Hikvision Anti Hacking Firmware Tested.

fwiw, the support page says Xprotect Essential 8.1/8.0 was tested with Hik firmware 5.0.0.

Edit: I know that doesn't mean it was actually tested with 8.1 or 8.0, only that whatever driver pack was tested, was tested with 5.0.0.

So any camera you buy after 5.0.0 is obsolete with Milestone, and you always have run your Milestone with the device pack they tested with? It seems a bit unbelievable that the compatibility is that delicate.

What I did not try is installing as an ONVIF device, not sure if it will or if it would make a difference, but at this point I need to get the customer happy. I am trying out Digital Watchdogs VMS as we I write this even though I bought the Milestone licenses. Why can't software just work as it should?

No, not at all. Everything SHOULD be forward compatible, meaning that any firmware version 5.0.0 or later is supposed to work.

However, all software has bugs, and each revision of the firmware brings the possibility of some problem. Nor is it feasible for a VMS to test every minor revision with their product the moment a hardware vendor releases one.

So in a case like yours, support will often have you rollback to the version of the firmware AND the version of the driver pack at the time they were last tested together. That is the only configuration that is known good.

That said I would follow the manufacturers support here.

Though honestly, I'm surprised that they haven't had you try this yet, but I am giving the benefit of the doubt.

Yes, the cameras could work as ONVIF and not work direct.

what is the current status?

I am still trying to get a hold of my Hikvision rep as the older firmware is not available on their site. Milestone does have the older versions but my last call with them had me putting in the newest version of the device pack.

I read Milestone's trouble shooting guide for this issue and they suggest cutting framerate to 4, compressing video to 50% and generally getting the bandwidth down. I have done systems with more than twice the 2-3MP cameras than this system has running at full resolution and 15fps using a 1st generation I7 and dident have any problems, so I hate to give the customer a hobbled system when he paid for the performance he should have.

I believe this is the Hikvision 5.0.0. firmware for the DS-2CD2032-I camera. From Hikvision's European website.

Don't trust me though, check it out, here's the release notes.

The release notes mention only ONVIF compatibility with Milestone 8.1 and this 5.0.0. firmware, NOT HIKCGI (direct drivers). Milestone client version 7.0B.

Use only if you feel confident it is the right thing to do.

William- if you have cameras at 5.3, you cannot downgrade. I believe you are at 5.2 still per your post. Our VMS integrtaion notes state from v5.1.0 to latetst are supported with a note to use Mielstone Hikvision8x3 driver.

Our integation person is contacting Milestone for further information and advise.

SHOULD needs to be way more highlighted and have tons of flashing lights as well as maybe a big horn sound going off. I have run into this same iussue with OnGuard VMS and AXIS cameras numerous times.

Check to see if under camera properties it is set to pull video via UDP.. If it is, switch to TCP. See if that helps. Milestone, by default, adds most cameras with a default UDP setting.

What device pack are you running ? And have you tried running an older one ?

Running 8.6d was upgraded from 8.6b at the advice of MS tech support.

I find it interesting that the Hikvision release notes say the camera is supported for ONVIF only, since the MS discovery finds it as a Hikvision. I don't want to set foot in customers home again without a solution, do you feel the ONVIF might solve issue?

And what device pack are you running with it ? I'm asking cause this monday I switched to 8.1 and I noticed 5 of my Samsung domes to also disconnect, all at the same time.

Changing device pack might solve your problem.

Rogier, to clarify, you upgraded from 8.0 to 8.1? And the Samsung domes are still down?

I went from 7.7 to 8.1. I only upgraded the device pack cause of the latest changes in the Hikvision PTZ functions. You can now decently get your PTZ positions in Milestone and not a list of 255 named by number.

The problem with the Samsung domes I managed to solve but not completely to my satisfaction. I had 5 cameras who would constantly connect/disconnect, all at the same time. All Samsung domes, but of different kinds (SNP5200/5300) and different firmwares. In the end I managed to pinpoint it to one of the 5. Once I disabled that one the others all came back and stayed online. I then moved the problem camera to another server not running 8.1 yet. Once I have some decent time I can go figure out what the exact cause of the problem is.

Woah, that's some clever troubleshooting but a messy situation!

Yes, I think it's worth trying. It's a popular camera, I came across posts from many people using it via ONVIF and many people using it in Milestone successfully, though it wasn't clear which way they were being integrated.

I went to my customers’ residence and installed Digital Watchdog which is displaying the cameras perfectly. So right now I have Milestone recording all the activity which it does perfectly ad DW displaying it which it does perfectly. What a mess, but it works until I get this figured out.

Will probably just get the DW license as I already have over 20 hours of unplanned time switching the server to windows 7 and messing around with settings, I really don’t think it’s worth the risk to roll back camera firmware for an uncertain result. Being an integrator is so much fun.

Beware while you are in this hybrid state, unpredictable things can happen when two VMSes think they own the same camera...

I plan to end the situation fast, right now it's stable. As a side note I hooked one of the Hikvision cameras to my Xprotect GO, sytem and it was perfectly stable. Maybe I could have rolled back the device pack and fixed it, I just ran out of the cutomers and my patients with the system.

For the record, may I ask, what was the total time spent on your problem by an actual Milestone engineer?

They spent 10 to 15 minutes on this. I explained the problem and was asked to check firewall was open, which it was. I was then asked to put the latest device pack in which I did and it did not help. This was actually bad advice, I probably should have rolled it back to the Hikvision tested device pack. Then I was told to roll back the firmware on the camera. The one bit of good advice was that I should run wireshark to look for anomalies in net traffic; this is why:

Although my customers video was stable when using Digital Watchdog, the error log on that program gave me some interesting info. What the logs showed was a bunch of dropped frames from the HIK's. Apparently the DW VMS is much better at hiding drop frames than Milestone, it also automatically dumbs down the camera settings. If I had followed the advice or if Milestone or if Milestone had the same logging ability I would not have been so quick to blame the Milestone VMS, which I really like. It looks like Milestone may have some logging option but it's not intuitive and wasent suggested.

The customer is happy and now that the threat of rip this out has diminished I plan to go back and find out what is actually dropping. I am thinking problem is with gigabit POE switch, Brighthouse switch or NIC card, everything else is cat6 and should be good.

Will do an update when I get back to system and learn more.


It's the power of the open platform :)