Maglock Not Releasing

We have a client that had an old access control system for some amenity areas, gym, laundry, pool etc. The interface between the controller and PC broke, and there was no replacement. So we did a panel swap and left all of the existing readers, locks etc.

Before the swap we did a walk thru and tested all doors. All doors worked from the reader and REX button.

After the swap, we tested and all doors worked.

We set security levels and retested and one door will not open. We triple checked all the security settings. The reader beeps and shows green, the software shows in the log it released the door. If I unplug power to the locks, the door opens. There is nothing else holding the door.

The staff said they had issues with the door before. I suspect an issue with the power supply/relay. I think it is sticking and not releasing the door.

I was by myself so I really could not do much troubleshooting such as checking the relay/power supply while the card was being read.

Has anyone had this happen?

Login to read this IPVM discussion.
Why do I need to log in?
IPVM conducts unique testing and research funded by member's payments enabling us to offer the most independent, accurate and in-depth information.