Hikvision NVR And Some Of Their Newer Cameras. Plug And Play Issue Perhaps With New Password

Over the last 3 HIKvision NVR installs, we thought we had encountered a "dead" camera or 2 using direct connect plug and play.

Discovered yesterday when connecting same cameras to a POE switch and running SADP, that the cameras were in fact not dead. Tried changing the IP address via SADP like we always do, and 12345 default password was rejected. Direct connected to the camera web page, and it required "registering" the camera with an 8 character password. Tried 12345678 and it rejected that. Requires an alphanumeric combo now.

Having done that, and checked the video, we then took it back to the NVR where it once again wouldn't detect it. Only way we could get it to work was to assign a similar IP address as the built ins like and then do a manual add with our new password. Kind of a pain and really ruins the beauty/benefit of an all HIK quick install.

Is plug and play dead now?

Is plug and play dead now?

No, it's just become "play and play around with a few settings".

In my experience, with the new security features which force you to "register" the cameras and nvrs first... Step 1) power up NVR and set new password Step 2) plug cameras to built in POE. It seems to take a little longer to recognize and connect to camera than it used to. But I think the process automatically changes the camera passwords to the newly created NVR password. I spent a lot of time troubleshooting the same issues until I realized that cameras connected AFTER NVR power up and password set were working. Then when I logged into these cameras the passwords had changed to NVR password instead of the default.

No. They simply require activating now which is a response to the default password scandal last year.

There are some versions of SADP which allow you to do this although I can't recall which versions.

Also, their NVRs will prompt you to do this on install as well.

SADP 3.x and up do this now - they detect the cameras as "Inactive" or "Not activated" or something, so you select them and set a password, and then they come up "Activated".

Big pain is, the new SADP doesn't integrate into HIK Tools.

Thanks Matt, I'll try the newer SADP. What HIK tools are you referring to? I'm really disappointed that they would do away with the plug and play feature. Seems like they could make that an option on the camera to leave it plug and play. Totally defeats the benefit of the built in POE/DHCP switch for smaller installs where there is virtually no security risk directly to the camera since you can't access it from outside except through the NVR

EDIT: after posting I found this: https://sassec.wordpress.com/2016/01/13/solving-hikvisions-nvr-plug-and-play-camera-detection-issues/

it explains the problem and seems to suggest that a firware update can resolve it but I'm not sure

I dunno, the latest firmware I tried updated my cameras with the default 12345 password to the new forced-change password... I'd test that on ONE camera first ;)

Hikvision Tools is this package:

Current version (as of the last time I looked, a couple days ago) is; the SADP included is v2.2.1.100, and it doesn't work properly with the newer cameras/firmware.

The newer v3.0.0.2 shows older cameras, and newer cameras with proper passwords set, as "Active"; newer versions without the password set show as "Inactive" and the only thing you can do to them is configure a password... THEN you can set an IP.

The newer one installs and runs completely standalone from the Tools utility though, which is a minor annoyance... I find the Batch Configuration and Focus Assistant utilities particularly useful.

My go-to source is Nelly's Security, but you can probably find them from any Hik dealer or probably from Hik directly.

EDIT: Scratch that, Hik USA doesn't seem to have the latest version of any of these - Hik Tools doesn't include all those utilities; they're all available separately. Tools has it all in one install.

Hik USA doesn't seem to have the latest version

As usual Hik Europe gets all the good stuff:

Hik Tools

But the camera will not even show up on the NVR, causing one to think perhaps the camera is dead. What password would one assign a "registered" camera so that the NVR would detect it via plug an play?

Try using the NVR password.

So to set up a "plug and play" HIK camera to an HIK NVR's built in POE ports, you first have to connect it via a separate POE switch with a laptop, run SADP and register the camera with the new NVR password? Then hope that the NVR figures it out when you plug it back into the NVR poe port?

Makes perfect sense.

I don't see why a closed loop camera would really pose a security risk when plugged into an appliance (NVR) with security on it. This to me is a step in the wrong direction. I can't believe the EZViz would do this.

You need to activate the cameras manually. Plug a laptop into the back of the NVR, find the cameras in SADP and activate them. Then go to NVR settings and manually add cameras with the username and password you created. Will work fine after that.

Old NVR's new firmware doesn't support the new security features. You could always use wbox cameras with the older firmware if you really didn't want to mess around with it.

Firmware update won't resolve it. They didn't do away with the plug and play. Older recorders just don't support the new protocol for activating new cameras. They're not releasing new firmware for those older systems anymore. A little annoying but it doesn't take long to work around it. Could be done with 16 cameras in less than 5 min.

John that link I posted seems to imply that if you select an acceptable password (8 characters A/N) for the NVR on initial start up, then it will send that pw to the cameras under plug and play and they will work like the old way. I can't confirm this yet

Just don't forget your NVR's password, or you'll get locked out of that. The recommended course is then to get a reset code from Hik or your dealer, which is applied through SADP to reset the password. There are several "reset code generators" available online though... I've had to use one once before. On my phone's browser.