Exacq Push Notifications On Mobile

Has anyone configured the new Exacq "push" notifications yet? I've updated my server to the latest (7.2.1.85489), but still get this error when I try to add a push notification profile. Has anyone been successful with this yet?

Push Notification setup on iOS


I just upgraded to 7.2.1.85489. It is working for me. I can push from the mobile app to a client and from a client to the mobile app. When you upgraded did you upgrade your webserver as well?

Not explicity. This is a relatively new LC box and ssh is not enabled. Is there a way to upgrade the webserver from the client app? Or a way to enable ssh on the server from the client app?

I'm not sure the web server is installed and will work on an LC box. I beleive I had this issue with a customer a few years back. I beleive they had to install the web server on a separate machine. You'll want to bounce this of Exacq however as this was a couple years ago and things could have changed.

It works you just have to set it to start up automatically. Disabled on those low power machines. Update it via the machine.

The web server is already installed on the LC box, because I'm already using the mobile app, which requires it. I've set up exacqVision on my own machines before, and I know how to update the webserver it from a command line.

I just thought that Exacq wouldn't still require a separate webserver upgrade on the pre-configured LC boxes. I've just never attached a keyboard or screen to the LC box, and hence never enabled ssh.

Thanks for your help. What do you think of the new version? Also, are you having audio issues? My cameras with audio no longer seem to play through the client, though audio does seem to be being recorded.

Like I said this was a couple years ago in regards to the LC boxes. They must have changed things since then.

One thing of note my server is running Windows, not Linux.

I just downloaded and installed on our in-house system so I haven't tested many of the functions as of yet.

I'll have to check the audio to see if it is working or not.

Interesting. I enabled ssh on my LC box, and manually updated the web service. Now I can see the Event Monitoring Profiles, and they seem to work if I have the app active.

However, if I attempt to enable an Event Monitoring Profile for Push Notifications, I get a message saying that push notifications are not supported, and that I should update my web service (again).

I am using Professional, and not Enterprise, but Push Notifications is not on the feature matrix as something that is only available in Enterprise, unlike VideoPush.

Are you using enterprise?

Maybe I can clear up a couple of things on this thread:

  • The web service is pre-installed on the LC-series.
  • The web service has an update feature built in. In the configuration panel on the web service admin page, you can check for updates and download the new version there. That was added I think one year ago.
  • There are two features using the word "push".
    • VideoPush allows you to push a layout between clients (mobile to client, client to mobile).
    • Push Notifications (new in 7.2) allows your mobile device to receive notifications of Event Monitoring rule triggers. This notification comes through the phone/tablet OS so the app doesn't even need to be open.

Is there a trick to actually get to the web service configuration? I don't see the link at the lower-right of the start page, which the documentation describes. Instead, I have the warning about power users:

Interestingly though, the mobile client otherwise works fine.

exacq web service

exacq web service

I hang my head in shame for not looking harder in the web server admin screen. That said, mobile push notifications aren't limited to Enterprise, correct? I have Professional, and I set everything up (I think) correctly, but I now get a pop-up on my iPhone, when I start Exacq Mobile saying something like "Push notifications unavailable on http://my_server_ip ...."

The only thing I'm doing differently from "typical" is that externally the Exacq web service is on port 22608...which is redirected internally to port 80 on the Exacq box (hence on the mobile device I tell it to connect to 22608).