Solved: Exacq With Axis Camera Lousy H264 Picture - Why?


I am testing the Exacq client in my lab and I see bad images from all my Axis cameras when I am using h264 streams. Bad means they look like they dropped some of the I-frames.

There is no resource issue since I am only looking at a single tile. MJPEG streams are a-ok.

My firmware is newer than what is mentioned on the Exacq web site.

When the cams are viewed natively from IE...they are a-ok. When viewed with other VMSs..they are a-ok.

All the other cams I have from other vendors do not show this.

Is there some trick when using Exacq with Axis?

Here is a pic after about 5 minutes...


What's the Axis camera firmware and the Exacq VMS version?

I have tried Exacq 6.4 and 6.6. My camera firmware is 5.40 which is higher than the 5.08 reported on the Exacq test site.

The FPS setting did not matter.

Hey Mike.

You say after 5 minutes, does that imply that the image is slowly degrading from higher quality to the picture quality that you are showing?

What does Axis system overview screen show for the clients and streams in use? Check the bitrate to see if it's not using some ultra low CBR, or the mobile stream for instance. is degrading over time. Cams with moving objects in them get worse faster.

bit rate is appx 800K...which is decent for a VGA sized image.

There is a H.264 de-blocking option in Version 5.6 and later of Exacq that could have an impact on only certain cameras. It is in the Client Configuration section for Admins, you might want try enabling and disabling and see if it has any effect.

Also, do you know how the GOP (I-P frames) are configured? Finally, what resolution is the stream supposed to be and what is the compression set to?

A.... this was a good post. This got me to thinking about verifying the situation on ALL my cams.... I had done only two different ones.

Turns out that of the eight different models I have...only three show the issue.

These were... M3113, M1113 and M1104.

The deBlocking had no effect.

Another good thing that happened is that someone from Exacq reached out to me to offer assitance. Kudos to that individual. We will chat sometime today.


Looking at the H264 video stream, i doubt deblocking filter disabled at your viewer's H264 decoder.

Problem solved....

The fellow at Exacq (Don) had me try a factory reset on the cams I was having problems with.

I did this and it worked! None of the cams have bad images in H264 mode after doing the 'Restore' reset from the camera's web interface.

Glad it got fixed!

Did the exacq fellow have any theory as to why that would work on two seperate cameras, that both worked fine with other VMSes at the same time?

Like some strange parameter that you might have set on both? Knowing the reason would let you rest assured it won't start "doing it again..." when you change some config param...

No...he did not offer a theory other than his 'experience' where he says starting from factory fresh settings sometimes made things behave better for him.

I test all kinds of VMS's in my lab and they all 'touch' the cameras settings.... so if one of the settings makes it a bit odd for another VMS.... it is not unexpected..but it would be nice to know which one it was.

I have run in to the deblocking filter being an issue with Exacq before. The picture will deteriorate in a strange blocking, diagonal pattern, then refresh at the i-frame.

Exacq had a "by device" setting that doesn't always work correctly. You can set it in the client settings on the server to force it on or off.

Glad you got your problem fixed. It sounds scary that a factory reset fixed it. BTW 5.0x is not that young, I would have expected Exaq to be tracking 5.2x or 5.3x at least.

Rodney, fyi, we have seen factory resets solve problems many times with Axis cameras.

? for all , Do you run all axis cameras in shielded cat 6 cable and are all components in emt, conduit or such.

Is this a axis only scenerio or have you had this issue with others ?

Just wondering about the ground potential of the devices, appliances, areas around the installations.

Was this just a fluke or software lock up on certain cameras ?

I'd like to think the shielded cat 6/conduit/whatever cabling ideas are not relevant. But I too have seen Axis cameras "lock up" and so I have to say it would appear to be within the realm of possibility that glitches walking up the ethernet cable can do this. In general at least.