Member Discussion

DW Spectrum Client-Server Time Offset

We are trying DW Spectrum for the 1st time and trying to get familiar with it. We have a time display issue and have not been able to figure out how to correct it.  I am hoping that someone familiar with this might be able to point out what we are overlooking.

The server time is correct, but for some reason, there is an 8 hour offset, so everything is displayed as 8 hrs ahead of actual time which is PST. I feel like I have looked at every possible menu and cannot find any place to change this offset. There seems to be no option to alter this setting? In the "Time Synchronization" tab, it shows the correct server time and an 8 hour offset. The "Current System Time" displayed is 8 hrs ahead.

I have looked at this on both the MAC & Windows version of the client and they are the same, no option to change the offset.

The server does have internet access and is accessible remotely.


Is the server run on Windows or Linux? Have you checked that the date and time settings in the OS are correct? Where does Spectrum indicate the incorrect time? Is it on the timestamps? Are you viewing the date and time via a client PC, or directly on the server? If using a client PC, make sure it has it's date and time set correctly as well.

Jon,

It is a BJ Cube LX, so Linux. The time is correct on the server and the time is also correct on any of the client PC's we have tried.  In the "System Administration", "Time Synchronization", it shows the server time (which is correct) and "Offset" of 8 hrs.  I looks like it is a way to make the time displayed on the client appear to be local even if the server is in another time zone.  The problem is that I do not see any option to change it or delete it.

I just got off the phone with DW support and they think that I need to upgrade the software on the Cube.  Since it will be updating to the version 3 that is not public release, they will need to assist me.  Very strange issue.  I am curious if that is a known issue or unique to us.

Sounds unique to me. We use Windows as our OS tho. I am currently having issues upgrading my server to the newest version of 3.0.0.14532. It downloads fine, but won't install the update. 

Have you tried the in client upgrade?

In-Client Upgrade:

Build Number:   14532
Password:   dn7y2w

Yes I've tried and it still fails. I think I need to backup, uninstall, install 2.6, patch up to newest 3.0, then restore data. 

WARNING!!! If you upgrade to v3 you will not have IOS remote access. The existing app does not connect.

 

You can still access them via their alternate app, DW Mobile

Too complicated for customers to configure/use.  Most clients had to remain on v2.4 because the app needed to be upgraded to v2.5 which wasn't an option. Version v2.6 remained compatible until now (v3.0).  DW Mobile works, but is not what customers want to use.

Why Windows OS for server? Don't you find it less reliable and harder to maintain?

Not at all. Win8 was a travesty, but W7 and WXP were pretty solid. W10 appears to be working well too. I'm running my home VMS on Server 2012 R2, but have plenty on W7 and W10.

We have seen some issues with memory usage leaks in Spectrum, but overall, not many issues. 

Are you talking about the cameras own timestamp overlay ?

Vincent,

 

You probably saw my response above that it is not the time stamp overlay.  The indicated time is actually 8 hrs ahead of actual time, recordings & live view.

Hello U1.
I work for the manufacture and I know what is the issue.
There is a simple fix. 

You need to upgrade to upgrade to

Build Number: 14540

In client upgrade password password: 93uuzw


Release notes for the patch are:


Release Notes:

  • Bug Fixes:
    • Requests to internet time synchronization server failed. Fixed.
    • Client crashed on hover over bookmarks at some hardware. Fixed.
    • Axis C1004 and C2005 Network speakers discovered with "No signal" message. Fixed.
    • Hikvision multisensor DS-2CD6362F-I had messed stream profiles across the channels. Fixed.
    • Arecont Vision AV20365 had incorrect sensors display. Fixed.
    • Vista VK2-3MPEFEDre tilt worked improperly. Fixed.
    • Zoom window applied to camera with very wide Aspect Ratio had the same AR parameters. Changed to more suitable.
    • Arecont Vision AV20275 maximum fps allowed value increased to 7.
    • Only key frames were replayed from Pelco Optera IMM12027 archive. Fixed.
  • Improvements:
    • Pelco D5220 ptz capabilities enabled
    • Cellinx|STH795 advanced ptz support
    • Redvision RVX-IP30-IRWL-W advanced ptz support
    • Content-type for POST requests is now automatically detected(HTTP request as an action)


 

We found some issue with the time server we used before. By some reason it does not answer to some servers. Moving forward we use our own time server.


If you have any issues, please send me a message. Thanks. 
Also let me know if you need link to download the installations files. 



Sergey,

 

If you have the link, that would be helpful.  Since this is a BJCUBE-LX, am I able to download directly to the cube or do I need to download to a USB drive?

Thank you for your help!

CTRL-ALT-A gets you to system settings. Click on updates tab. Then click the top drop down, mine says Latest Available Update, and change it to specific build. Use the creds Sergey gave above. It should upgrade fine. 

Wow, that seems to have resolved the time offset issue! It was driving me crazy.

Thanks you guys!