Dahua Password Change Problem

For Dahua SmartPSS, member says he "changed the password on the vms, when i tried changing it on software for remote viewing it said account locked"

Anyone have any ideas?

"changed the password on the vms"

Does he mean he changed it in the web interface of an NVR?

If so, it's possible that the software rapid-fire tried the wrong password to connect to that NVR and the NVR auto-locked the account. If you go into PSS and take the device offline, then change the password in the NVR, then enter the new password and take the device back online, it should avoid that.

That's actually a good example of the annoyances of these intrusion detection features. I had the same thing happen between Exacq and a Dahua camera.

I had the same thing happen between Exacq and a Dahua camera.

I remember you saying something like this happened with a Hik and Exacq as well. In that case, the originating IP gets locked, not the account, though.

Just read to reset (at least some) Dahua DVRs/NVRs to default you can pull the button battery for a minute.

Sounds like he changed the local password for SmartPSS, not his NVR/DVR. This would explain his inability to connect remotely to the device.

This is a screenshot of SmartPSS (on Mac OS X) showing the account locked problem.SmartPSS reports the DVR to be offline because the account is locked.

In this instance, a child had been playing with a computer which accessed the DVR. Presumably the child tried entering the account password too many times so the DVR automatically locked the account. There's nothing in the manual about how to solve this so I expect I'll have to obtain help from Dahua support.

All you have to do is cycle power on the unit to unlock it.

Thanks Jon, that didn't work in this case but I have read that it did work for others.

My guess is that there is a client somewhere trying to log in persistently. It is locking you out as soon as it boots up. Try deleting that account and creating a new one with a different account name.

Hi Jon, I don't think I can (or should) delete the admin account. However we'll try creating a new account with the same privileges as the admin account and then see if that works around the problem. Thanks for the tip!

Hi Jon, thank you very much for your tips which have resulted in success!

I had the customer create a new admin account and that has worked around the problem and now SmartPSS can remotely access the DVR and see all the cameras.

While shutting down the DVR for a while did unlock the admin account, it rejected the password for that account even after resetting the System settings to factory defaults which I believe should have set the password back to admin. I hope to solve this mystery some day but meanwhile your workaround has worked perfectly. Thank you very much for your excellent advice.

Strangely, defaulting through the UI does not reset some areas, networking and user accounts are the two I can recall.

Thanks Jon,

The DVR automatically restarted last night as it was scheduled to do. The problem remained today. I will ask the customer to try powering it down fully and then start it up again and see if that makes any difference. Thanks for the tip!



You can also use the local login account 888888 (default password 888888) to unlock the DVR. The 8 account only works from a mouse and monitor connected to the DVR, it can't be used to access the webpage or as a PSS login.

Hi Bob, thank you for your tip. The customer has been able to log in with the 888888 account while sitting at the DVR. When he went into Main menu > settings > system > account, we were surprised to find that the admin account status was listed as Normal rather than Locked. I had him log out and attempt to log in as admin locally on the DVR. This caused an alarm to sound on the DVR and a message appeared stating the account was locked. So the customer successfully logged back in as 888888 and this time the admin account status was listed as Locked which is what we had expected in the first place.

I had the customer change the password for the admin account and then save it and log out. He then attempted to log in as admin with the new password and the alarm sounded and the message appeared to say the account was locked.

At this point, I felt that returning the user accounts to factory defaults might help so I asked him to go to Main menu > settings > system > default and then uncheck all options except for System. He clicked Apply and then restarted the DVR. The Startup Wizard appeared but when the System Login subsequently appeared, he tried the new password which was rejected. He also tried the old password admin but this generated an alarm and the account was reported to be locked again.

The only thing I can think of that we haven't tried is defaulting all settings although I was hoping to avoid that if possible. Can you think of anything I may have overlooked? Thanks very much for your help!

The only thing I can think of would be Jon's suggestion that something on your network is trying to login as admin and locking the account. You could unplug the network connection from the back of the DVR and reboot. If the account still shows as locked with no network connections available, then you have some kind of glitch in the software.

However if the account is unlocked on reboot, try plugging the network cable back in. If the account switches to locked in a few minutes then you know that something on your network is tripping the intrusion feature.

I also like Jon's idea of creating a new account. You can make another account from the DVR main screen and use it to interface with PSS. If the account setup has a checkbox called "reusable", check this to allow more than one PC to connect.

Hi Bob, thank you very much for your helpful suggestions. Your idea of shutting down the DVR and unplugging the network connection matched the advice I also received from Dahua engineers. They suggested leaving the DVR off for 30 minutes. This did unlock the account but that still didn't solve the problem as the admin account rejected the admin password as invalid even though the System settings has been set to factory defaults.

Given that, the customer used the 888888 account to create a new admin account and that has solved the problem. I'd still like to work out what went wrong and hope to investigate this further. However the customer now has his problem solved and is very happy, as am I! Thanks again for your excellent help.

Luke, glad to help out. Thanks for posting the follow up and sharing the outcome.