What Causes Slight Corrosion On 8p8c Connectors?

I have an enclosure where all connections terminate but there was some corrosion on both male and female rj45 connections.There is no water signs in enclosure but i did clean up female connection and replace male.I also put dielectric grease in female to ward of future issues.I used a silicone base one called super lube.Has anyone had experience with stubborn moisture penetration and how one prevents these type of issues?I know if there's a way in water will find it .I use these waterproof connectors with seals on them and i use electrical tape on them as an extra measure.Maybe should be using this dielectric grease on seals of rj45 connectors as well.

Login to read this IPVM discussion.
Why do I need to log in?
IPVM conducts unique testing and research funded by member's payments enabling us to offer the most independent, accurate and in-depth information.

** ******, *** *** ********** **** ******?

* **** **** ** * **** ******* *******, **** ***** component ************* *** ******* ** *** '**** *******' ********* **** high ****** ** **** *** ****** ******* ** (**** *********) gold *** ******.

*** ********* ***** ** ****** *** ***** ***** '****' ** the ***** *** **** ***, *** **** **** *** ******* oxides *** ** ******** ********* ***/** ***** ***.

******** **************** ******* *** ********** ******, *** *** **** ***** ** a ****** (** *** ** ***) *** **** ***** ******* as *** ***********, *** ** ******* ********** *******.

******** **************** ******* *** ********** ******...

***********. ** * ***-******* **** *** ***-******* **** ***** ******** corrode **** **** * *** *** **** ******* ****, ** long **** **** *** **** *****?

********* *** **** ***** ******* *** **** **** ***** *** the (*** *******) ******* ** * ****** *********, *** **** necessarily ******* * **** *** ****.

*** *********** *** **** **** ***** ** **** **** **** are.