Camera View-Split Screen Problem

I am looking to see if anyone out there can provide some advice as to whether this is a typical problem or not, what causes it and approaches to fixing it. Thanks in advance!

We have had some recent problems with 4mp varifocals, and now a 3MP PTZ displaying a split and/or "rolling" screens. Does anyone have similar experience with this? Our initial installations went well, everything displaying properly for a month-3 months and then we get the call that the customer is getting a split screen on one camera. The bottom half of the VMS image is often displaying on 1/4 of the top of the view.

Thanks for your help!


What type of camera? Just a hunch, but check if ROI is enabled on the camera. I've seen where "X" stream is cropped to a Region Of Interest on some cameras...I think it was Speco.

I saw something similar once before where I had a VMS UI open for weeks. It was running fine and then one day I noticed the camera images were corrupted in a way similar to what you described - they were "split", but they weren't rolling, so may not be the same thing. In this case however, I do not believe it had anything to do with the cameras, and I put it down to a video card driver bug on the client machine. I restarted the computer running the UI and the problem went away.

The bottom half of the VMS image is often displaying on 1/4 of the top of the view.

Does that mean that it is displaying with an extra-wide aspect ratio, or??

Undisclosed 1: Thanks for the suggestion, it doesn't have to do with the ROI on this cam....

Undisclosed 2: Thanks for the suggestion. Re-starting the computer did work a couple of weeks ago. at one location. As for the others, we have tried re-starting and that hasn't worked. The rolling problem is only on the 3MP PTZ.

Undisclosed 3: Thanks, but no, they are not displaying with an extra-wide aspect ratio.

I really appreciate your responses!

Christine, can you be more descriptive of what you mean by "half the image displaying on 1/4 of the view"?

Also, just to clarify, we are talking about only one model, "a 3MP PTZ", but multiple cameras?

First step is to find out whether it is caused by the camera or if it is on the VMS side.

You could ask the following questions.

1) Next time it happens, log on to the camera via the camera web interface at the same resolution and fps as the stream the VMS uses to connect to that camera if possible, and see if the problem exists on the live page of the web interface. If so it is most likely a camera problem, if not, it still might be caused by the camera or the VMS side.

2) After you rebooted the computer and the problem went away, did you try playing back video that was recorded when the problem existed? If the video plays back correctly, then that tends to point towards the VMS side.

3) Does the stream from a particular camera always display "split" on all client workstations displaying that camera, or does the same camera play broken on some but no others? If the same camera displays OK on some, but not others, then it also tends to suggest the VMS side.

4) There are multiple computers running the client UI where this problem happens, are these all the same model of computer? more importantly are they the same video card?

5) How many camera streams are being displayed simultaneously on the UI e.g. 4 by 4 tiles, 5 by 5...?

6) What video card are they using?

How many viewing stations have the VMS client installed?

Do they all exhibit this flaw?

Are they all similar hardware, same graphics card, driver, client version, Windows version, etc?

Is this flaw also found in the web interface of the camera?

Have you looked into newer firmware for the cameras?

What brand/model of cameras and VMS is in use?

Thanks all so much for your input. All great questions. Long story short, we were able to pinpoint all 3 of our problems to the software.

We also have an ongoing fourth problem at a different location with multiple 360's. For months they weren't able to work properly at even 7FPS on a robust NVR, plenty of bandwidth and ideal setup.

It turns out today, after trying a different free downloadable VMS, everything is now working well! The free VMS was just to test, but at least we know for sure now. Worrysome, and aggravating, but at least the problems are at bay for now.

What were the 3 problems? Bugs or mis configs?