Axis P1204 Only Showing IP Address, No Image

Hi all, I know I'm missing something but can't seem to figure out why I am not able to see an image.  Here is the setup- using an openeye hybrid server, 4 openeye cameras and 1 Axis P1204 covert (for door frame) at a local retail store.  I have never used Axis btw.  I hooked it (Axis cam) up to the server (via Trendnet POE switch) including the "dvr" that comes with the Axis camera.  The POE switch powered the dvr/cam and I was able to view the video via the webpage which I accessed through the openeye video setup.  On the actual openeye, I can only see the IP address of the axis camera so it does see/find the camera but does not show image.  The Axis is set to MJEG, not H.264 (not sure if thats important).  So scratching my head on this as I am thinking I'm leaving something out... I do have it set to ONVIF on the openeye.  The other cameras (openeye IP, mixed with analog- brand unknown since they were existing cams) are showing up with no problem.  This is a stand-alone system.  The only issue thus far is this Axis.  Any ideas?


If you're trying to use ONVIF to communicate with an Axis camera you will need to pop into the security settings on the camera and specifically add an ONVIF user. Off the top of my head I can't recall but there may be a "enable ONVIF" checkbox, otherwise you just need to create the ONVIF user and password, then use those credentials in your VMS.

Thanks Joshua however, in the openeye camera discovery, the Axis camera is showing up twice. One as an Axis camera and the other as an ONVIF camera. I have tried both but have been unable to get video to show.

Not having experience with openeye, I would recommend the following:

- if openeye have a recommended firmware for the camera, upgrade/downgrade to match. If they don't, make sure to use the latest firmware

- time sync the camera with the server and set the timezone correctly in the camera as well

- disable Windows Firewall if enabled, and re-enable with the necessary exceptions later when things are working

- if all else fails, check with openeye for recommendations

If you're comfortable with Wireshark you may be able to narrow in on the problem by watching the HTTP requests and responses while waiting for someone with more openeye-specific experience.

Here's a +1 to the Wireshark recommendation.

Occasionally, problems are obscure enough that it might be more logical to just trace it out in the first place.

I've done lots of audio troubleshooting on Milestone via Wireshark.

Super helpful tool!

Have you contacted OpenEye support? There's many little things that might not match up that can cause such issues integrating with VMSes. We might be able to guess it but OpenEye would know best on something this specific.

John, I did contact openeye however the tech redirected me back to Axis. I've been informed since to talk with specific techs at openeye who are more familiar with Axis. I'm doing that tomorrow morning. I'll post what I find out and it resolves the issue.

I just came off of a 25 camera Axis installation. For the life of me I could not get 6 of the cameras addressed and added to a system. After quite a while it turns out that 6 of the 25 cameras had some sort of firmware corruption from the factory. This is what tech support tells me. 6!! Almost 25% of the cameras. Really?

I had to flash them with the latest firmware via FTP from the command prompt which was very time consuming.

They are back now so maybe you should try to send up the latest firmware with the help of tech support of course. Have a real bad taste in my mouth after this one.

Sounds like the camera could be in "non-decoding mode". From the support page:

I'm pretty sure it's not checked but I'll look tomorrow just to be sure. Thanks for the tip.

Hello Undisclosed Integrator #1

The most frequent cause of this is the above mentioned ONVIF user settings on the Axis camera not being enabled. Please verify that the camera is correctly enabled for ONVIF connections. If it is still not working, please call OpenEye support and request to speak with an L3 agent and we would be happy to help (888-542-1103 option 2).

Thank you,

J Okert
OpenEye Support

It was a relatively simple fix under the Axis webpage menu and title "Webservice". Once I ticked the options there, it worked. I'll post photos later if anyone is interested.