Axis Camera - Access Denied After PW Change With %

I'm hoping someone has run into this before...

I needed to change the root password on an Axis P3367, and by chance the password I chose contained the % character (not a big deal, right?). So, after changing the PW, it presented a credential dialog but would then not accept the password when I re-entered it. It also would not accept the previous PW, or "pass". So I power cycled and same thing. OK, I know, I know..."then obviously he just didn't remember the password he set it to". I thought the same thing but...

I then went to a second P3367 demo camera on the shelf also running FW 5.70 and I changed the root PW to something normal like "bravo933" and it worked as expected. OK, so let's give this other PW a try. I attempt to change to something with a % character (like kdje%1466) and same issue. It refuses to accept the new root password. Only way to fix it is a power cycle from front button push.

A few last comments: 1) I haven't checked on other FW's; only their latest. 2) Oddly, it WILL accept the % characters in the initial configuration screen.

Sooo...this is big problem because reaching the camera involves entering land co-owned by a nunnery and a nudist country club. Please do not make me roll a truck for a factory default. Please.

Any help will be significantly rewarded. Thank you.


Ok, so it could be that the percent sign is being evaluated as a special character by either javascript or the linux/unix shell or something in between.

its a long shot, but it shouldn't hurt to try this:

type the password using %% instead of just %.

if that doesnt work try using \% instead of %. Note that is a backslash, not a forward slash.

what side is the camera on, nudist or nun (of my business)?

Also, try skipping the % sign altogether.

try different browsers, axis camera tool, etc...

do you know how to ssh into it?

So I defaulted a M3006 with firmware 5.55 and chose a new password using an embedded % it and it worked fine.

I also changed a P3367 with firmware 5.60.1 root password to one with an embedded % and had no problems logging in and changing it back. Note that I did not factory default this one, only changed the root password because its being used and didn't want to chance it getting screwed up.

What exact OS/browser and version did you use? There are sporadic complaints of people saying they have had problems with special characters and axis camera, but no official word that I was on Axis site.

Thanks for the quick responses - much appreciated.

To answer Undisclosed A:

1. Tried replacing % with %% and \% as you suggested but no luck.

2. On nunnery side...I've never asked too many questions.

3. Tried Chrome, Firefox, and IE (Windows 7) with same results and yes - I can SSH into it but same issue when it asks for root password.

Also, FYI I have been able to reproduce this again on the bench...here's steps if you're interested

(Using P3367-VE with FW 5.70*, using Chrome or IE)

1. Factory default

2. On first access (I have used Chrome and IE), assign password of bravo933

3. Answer questions about capture mode and power line frequency --> LiveView

4. Go to Setup --> Security --> Modify root user

5. Enter new password of kdje%1466

6. You now cannot access the camera without performing factory default

* Haven't checked other FWs yet

Brian, fyi, I forwarded this to our contacts at Axis to see if they have any feedback.

Just to let you know, I was able to replicate the % bug with my M3006 after I upgraded the firmware to 5.70.1.