Axis Cameras - No Video, But Still Pingable??

I have been chasing a problem on at least two customer sites now. There are Axis cameras where the video would stop working but it's still pingable. I have seen this in different models now, Q6045, Q6044, Q6034 and 233D. Customers do NOT want SSH, telnet nor ftp access open. So no backdoor rebooting. Hence, the only way to get video restored is a power cycle of the camera. Not the solution, by no means

Has anyone experienced these symptoms in other Axis models? And, if so, has Axis addressed the issue? We have spoken to engineering there. And it appears they are aware of said issue. I was wondering if anyone has received a definitive FIX for the problem.

Thanks


Can you power cycle the cameras via Axis Camera Management?

I've passed this along to Axis to ask for comment.

I have seen this a couple times lately. I am not sure what it stems from yet. Are you able to get the web interface? The couple that I have seen are pingable but the web interface is not accessible.

We have seen this issue on some Q6034-E and Q6044-E cameras. Upgrading to the latest firmware seems to have fixed it.

Thanks all for the responses. We cannot get to camera web interface. Nor can we utilize CLI options.

I wil confirm latest and greatest FW though.

Hi Undisclosed A, just wanted to follow up with you on behalf of Axis. Since these types of issues could be caused by a number of things, we aren’t able to provide a one-size-fits-all fix. Our team will need more detailed troubleshooting to figure out the exact cause and to understand what exactly you've already tried since you've been in touch with support. Every case is different!

To help resolve the issue, I'd like you to speak with our Tech Support Manager. Please give me a call at 978-614-2137 so I can connect you with him directly (as opposed to dialing in to the general support line which works based on queue).

Thanks, and I look forward to hearing from you!

I have had this issue for sometime with some 214PTZ. Seemed to occur after upgrading them to the lastest & greatest FW. Changed power supplies multiple times but no fix. Had issues with not being able to save the auto return to home. After dealing with Axis support, they sent through later & greater FW, since this upgrade the cameras have not gone offline with no access to web interface. Can save auto return period as well. It was mentioned that the preset table was corrupted. Just strange that it happened on all 12 cameras after the FW upgrade. However, well worth spending some time with Axis support on this.

Cheers

I hear about this from time to time. As far as I can tell Axis repeatedly has issues with cameras locking up the video processing. I think it's weak network error processing since I've seen it with flakey networks and due to security scans. Quite often this I find this is "corrected by a firmware update" which really just means I'm the n+1-th victim of this bug that they're not admitting they fixed. The nature of the beast seems to be that the protocol stack doesn't die, jus the video bits. This would produce the symptom of ping-but-no-video.

Hint to integrators: throwing every spare in the back of your truck at this problem looks REALLY STUPID to those networking people at the customer site watching you debug this. It's much more appropriate to make a clear effort to check with the vendor about firmware upgrades. (yeah, there's a separate ipvm.com thread for that...)

BTW if the camera management software can remote reboot the camera with no password, be afraid - it's a security flaw.

I've had similar symptoms with a number of P1214-E cameras, where the web interface was still accessible, but there was no video (video displays in the web interface would just be a grey box). A power cycle would bring it back every time (yay for managed PoE switches) but it's frustrating to have to do that repeatedly. Worse, the problem would only crop up every few weeks, so every time a fix was tried (default settings, new firmware, etc.) we'd have to just wait, sometimes a couple months, until it would manifest again.

I sent every log file to Axis, both before and after power cycle... the best they could come up with was MAYBE interference on the network line, which was a distinct possibility, since the runs all followed line voltage inside the center pole of giant fixed "umbrellas" on a restaurant patio, and the interface box was inside a housing at the top where all the heater and lighting wires split out (fortunately the lighting is all low-voltage LED)... and the most-affected unit is probably getting close to 300' from the switch.

Some others did it occasionally as well, and I swapped the interface boxes between a few of them, but the problem remained most prevalent at the same one. Also re-terminated the UTP, and removed a wadded mess of UTP where the A/V installer had not bothered to coil it properly after adding the speakers to the fixture. Finally I swapped the sensor module with another unit that had been working solidly... but still to no avail; with several weeks it was back to the same hijinks.

Since these are all in an outdoor (though completely covered) area near the ocean, I also opened up a few of the interface boxes to check for corrosion, but found nothing. But it did occur to me, the last time I did a swap, that maybe the jacks WERE still getting a bit of oxidation on the pins of either the 8P8C on the network connection, or the 6P4C on the sensor connection... so the last thing I tried was to add a bit of dielectric grease to all those connectors, then wrap the whole assembly in a freezer back along with a desiccant pack, squeeze the air out, and zap-strap them shut.

That was all within the last couple weeks, so now the waiting game begins again...

If you have "it happens ever few weeks" syndrome then it can be useful to monitor the network stats (at the camera or at your fancy PoE managed switch.) If you are accumulating errors over time that could relate. Also this could correlate with (when it rains, some irregular delivery that makes a big truck drive over the cable, etc.)

True... although the Axis server logs are pretty inclusive, and even they couldn't come up with anything definite.

It's happened in all kinds of weather; trust me, I've looked at every external factor I could think of... the fact it loses JUST video (not network) and a power cycle brings it back points to something more "local". The way it's happened to multiple cameras, and never more than one at the same time, points to something more subtle.

I had similar issues with the m3 cameras the first year they were released. For some reason they would be accessible via web application but would stop streaming to exacqvision. If I went to 5 frames per second, all was stable. Anything above this and they would lock up eventually within 30 to 60 days. I gave up on the phone calls and called it good at 5 frames per second for the couple of hundred I deployed, I soon after moved to another camera brand ( I believe this was around 2010-2011).

i have had firmware issues with axis (240q, p33. 207) many times over the years since 2007 which has been impossible to clarify. This is, in my mind, definitely a firmware issue.

Thanks for that, Jeff - if this continues I might try changing the frame rates; they're currently all at 6.

I also have a P3006 and a 233D that it happens with. They are in a 'lab' setting, so I never really noticed it before.

@Kelly: Is it possible as a workaround to run a watchdog reboot task? One that would automatically cycle power on detecting loss of video? Surely someone has created just such a kludge, no?

Or what about a trigger off the tamper detection alarm to reboot?

It may also prove helpful to use SNMP to monitor the camera(s). This may or may not be better than the Axis logs themselves, but could also provide a different 'perspective' on the issue based on the sensors that are setup. Ethan wrote a nice article on this last month and just wanted to make you were aware in case this helps.

Network Monitoring / SNMP for Video Surveillance Guide

Had this happen with Axis Q60 series PTZ's that were accidentally plugged into 15W PoE injectors. It's enough power to fire up the board to ping it, but not the camera imager. The Axis PTZ's need 30W or 60W power depending on the model.

Had a similar issue with a 233D speeddome. I extended the output of the power supply by 50 ft or so with 22 gauge. As I recall, you could even move the dome, but no picture...

Had an old Spectra III do something similar. Worked great all summer. First cold snap the camera would reboot every time they moved it, because the fan and heater were drawing too much power. Was no way I'd be able to replace the 18/2 power, so I upgraded from a 24VAC power supply to 28VAC.